Ticket #506 (closed defect: cannot reproduce)

Opened 5 years ago

Last modified 3 years ago

can't run program in 'regular' dos window - VISTA

Reported by: modiintech Owned by: azawawi
Priority: minor Milestone:
Component: editor Version: 0.45
Keywords: Cc:

Description

Hi,

I'm new here (& to Perl/programming altogether) so I apologize ahead of time if I'm doing anything wrong.
I was asked to report the following as a bug in Padre -
I'm running windows Vista Home Premium (32bit). I downloaded the msi file and installed Padre successfully. I also followed the instructions in the "Getting Started with Padre on Windows" at the following link - http://padre.perlide.org/howto.html .
I started by reading The Beginning Perl book of Simon Cozens. After writing the Hello World program I tried running it in a dos window (by typing "perl hello1.plx") but was unsuccessful - I was able to run the program in Padre by hitting F5.
With some help & after poking around a bit I figured out that the problem is with running cmd in 'regular' mode vs. running it "as administrator" (this is only in Vista, not in XP...I think this will also be the case with Windows 7).
I'm attaching 2 txt files that show the output of the commands:
echo %PATH%
perl -v
in 'regular' dos window & in a dos window run as administrator.
FYI - the output from the echo %PATH% command in the run as administrator window matches the Path entry in the GUI - under Environment Variables.

Again, please excuse any newbie mistakes.

Attachments

output of cmd windows.txt (2.8 KB) - added by modiintech 5 years ago.
output of both cmd windows

Change History

Changed 5 years ago by modiintech

output of both cmd windows

comment:1 Changed 5 years ago by azawawi

  • Owner set to azawawi
  • Status changed from new to assigned

comment:2 Changed 5 years ago by azawawi

Could you please test if this bug is still valid in Padre 0.46 ?

Thanks for your time :)

comment:3 Changed 3 years ago by azawawi

  • Status changed from assigned to closed
  • Resolution set to cannot reproduce
Note: See TracTickets for help on using tickets.