Opened 5 years ago

Closed 3 years ago

#541 closed defect (fixed)

wrong outline can get displayed for a document

Reported by: rhebus Owned by: zenogantner
Priority: major Milestone:
Component: Outline Version: trunk
Keywords: outline Cc:

Description

Steps to reproduce:
Open a big file and a small file. I did it with Padre/Wx/Main?.pm (big) and Wx/Perl/Dialog?.pm (small.)
Select Main.pm tab, then (quickly!) select Dialog.pm tab.
The outline for Dialog.pm is displayed, then after a while, the outline for Main.pm replaces it.

I would guess that the Main.pm outline calculation takes longer to complete than the Dialog.pm outline calculation, and when it finishes, it doesn't bother to check whether Main.pm is still the open tab.

This is related to #538, I'd guess.

Attachments (1)

wrong-outline.png (92.5 KB) - added by rhebus 5 years ago.
screengrab showing wrong outline displayed

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by rhebus

screengrab showing wrong outline displayed

comment:1 Changed 5 years ago by Sewi

It also happens when opening files or creating new ones - the outline or function list isn't updated as long as you switch tabs.

comment:2 Changed 5 years ago by zenogantner

  • Keywords outline added
  • Owner set to zenogantner
  • Status changed from new to accepted

I can reproduce this.
It is because the computation of the outline tree is a Task that is started when
the document is switched or (after a certain interval) when the file has changed.

If you switch in the mean time, the task will finish its work nonetheless and
show the computed data.

comment:3 Changed 5 years ago by zenogantner

I think it is fixed in r11400.

comment:4 Changed 4 years ago by szabgab

  • Component changed from editor to Outline

comment:5 Changed 3 years ago by szabgab

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.