Opened 5 years ago

Closed 4 years ago

#579 closed defect (fixed)

Commenting/uncommenting comments the last unselected line

Reported by: azawawi Owned by: azawawi
Priority: minor Milestone:
Component: editor Version: 0.57
Keywords: toogle comments Cc:

Description

Scenario:

  1. Open an existing Perl script
  2. Select two lines of code to comment
  3. press CTRL-Shift-C (Toggle comment)

Correct behavior:
Only the selected lines should be commented

What happens now (aka the bug):
The last unselected line is commented which is annoying

It also happens on Comment Selected Lines (Ctrl-M) and UnComment? Selected lines (Ctrl-Shift-M)

Change History (8)

comment:1 Changed 5 years ago by azawawi

And selection is also lost!

comment:2 Changed 5 years ago by azawawi

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r7897

comment:3 Changed 5 years ago by azawawi

  • Resolution fixed deleted
  • Status changed from closed to reopened

It does not work on win32

comment:4 Changed 5 years ago by azawawi

  • Resolution set to fixed
  • Status changed from reopened to closed

Finally fixed in r7947

comment:5 Changed 4 years ago by mateu

  • Keywords toogle comments added
  • Priority changed from major to minor
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 0.46 to 0.56

Looks like a regression. when I use CRTL-SHIT-C to toggle to un-commented two lines, the second line remains commented

comment:6 Changed 4 years ago by mateu

  • Version changed from 0.56 to 0.57

This problem also occurs using CRTL-M, last line selected does not get commented.

comment:7 Changed 4 years ago by zenogantner

I guess this is because of the cursor position.
If you select two lines and move the cursor into the last selected line, Padre behaves.

comment:8 Changed 4 years ago by zenogantner

  • Resolution set to fixed
  • Status changed from reopened to closed

I believe this is fixed in r12479.
Please check on win32.
Re-open if necessary.

Note: See TracTickets for help on using tickets.