Ticket #617 (closed defect: worksforme)

Opened 5 years ago

Last modified 3 years ago

Random crashes while editing (syntax highlighting suggestion)

Reported by: Floyd-ATC Owned by: azawawi
Priority: major Milestone:
Component: editor Version: 0.47
Keywords: random crashes while editing Cc:

Description

I keep getting random crashes while editing perl 5 scripts. More complex scripts seem to cause this more often, suggesting that syntax highlighting or error checking is the cause.

PPI Experimental, PPI Standard and Scintilla all exhibit the same behaviour.

Since there is no crash handler, I'm unable to quote any error messages.

Change History

comment:1 follow-up: ↓ 3 Changed 5 years ago by azawawi

What's your environment (OS, perl, Wx)?

comment:2 follow-up: ↓ 4 Changed 5 years ago by azawawi

  • Owner set to azawawi
  • Status changed from new to assigned

comment:3 in reply to: ↑ 1 Changed 5 years ago by Floyd-ATC

Replying to azawawi:

What's your environment (OS, perl, Wx)?

Sorry for not including this info. I will add it once I get back home (about 8 hours from now)

comment:4 in reply to: ↑ 2 Changed 5 years ago by Floyd-ATC

Replying to azawawi:

WinXP pro SP3
Perl v5.10.0
Wx 0.91
wxWidgets 2.8.10

comment:5 Changed 3 years ago by wwe

I didn't noticed any crashes while editing for a while. I think the stability has improved a much since 0.47. I would suggest to close it...

comment:6 Changed 3 years ago by azawawi

  • Status changed from assigned to closed
  • Resolution set to worksforme

Closed

Note: See TracTickets for help on using tickets.