Ticket #619 (closed defect: worksforme)

Opened 5 years ago

Last modified 2 years ago

Multiple files open, editor switches between tabs by itself

Reported by: Floyd-ATC Owned by:
Priority: major Milestone:
Component: editor Version: 0.47
Keywords: Cc:

Description

When working with more than one files in the same project (main script plus a few custom modules) the editor will sometimes switch back and forth between two different files automatically. Trying to click on the tab I want to focus on accomplishes nothing.

The problem is triggered by normal editing of the modules and will occur every few minutes, effectively preventing any editing while it goes on. After a minute or so the problem is gone.

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by Sewi

Which OS are you using?
Could you try it using the trunk version?
Does Ctrl-Tab work for you?

comment:2 in reply to: ↑ 1 Changed 5 years ago by Floyd-ATC

Replying to Sewi:

Which OS are you using?

WinXP pro SP3
Perl v5.10.0
Wx 0.91
wxWidgets 2.8.10

Could you try it using the trunk version?

If I can figure out how, without breaking anything

Does Ctrl-Tab work for you?

Sort of.

It changes tabs after 2-3 seconds, but after a few times it actually triggered the tab switching bug and when left alone it kept switching back and forth for several minutes.

comment:3 Changed 4 years ago by waxhead

I've seen this in the past as well, however not seeing it lately.

Can anyone else comment on this?

comment:4 Changed 4 years ago by zenogantner

I have never seen this.
Floyd-ATC, do you still observe this behaviour?

comment:5 Changed 2 years ago by adamk

  • Status changed from new to closed
  • Resolution set to worksforme

Nobody seems to be able to replicate this, with no further information we cannot progress. Closing.

Note: See TracTickets for help on using tickets.