Ticket #620 (closed enhancement: not a bug)

Opened 5 years ago

Last modified 5 years ago

Suggestion: Hotkey to indent/unindent selection

Reported by: Floyd-ATC Owned by:
Priority: minor Milestone:
Component: editor Version: 0.47
Keywords: indent unindent hotkey Cc:

Description

When pasting code into an existing enclosure, it is usually necessary to indent or unindent sections of the code to match the brackets. Example:

enclosure {

enclosure {

pasted code; # Should be indented
pasted code; # Should be indented
pasted code; # Should be indented

}

}

Some other editors have a hotkey to accomplish this. For example in 'joe' I can mark the lines in question and hit Ctrl-K "." to indent or Ctrl-K "," to unindent.

Change History

comment:1 Changed 5 years ago by Sewi

  • Status changed from new to closed
  • Resolution set to not a bug

Padre also has a hotkey for this: Tab (and Shift-Tab for move-to-left).

Note: See TracTickets for help on using tickets.