Ticket #642 (closed defect: not a bug)

Opened 5 years ago

Last modified 5 years ago

ProcessSteam: Run missing

Reported by: Sewi Owned by:
Priority: major Milestone:
Component: editor Version: 0.47
Keywords: Cc:

Description

Open a test (for example one of Padre's own tests) and select Run -> Run this test:

DIE: Can't locate object method "Run" via package "Wx::Perl::ProcessStream::Process" at /home/sewi/padre/Padre/lib/Padre/Wx/Main.pm line 1733.


at /home/sewi/padre/Padre/lib/Padre/Wx/Main.pm line 1733

Padre::Wx::Main::run_command('Padre::Wx::Main=HASH(0x954abb8)', '/usr/bin/prove -bv /home/sewi/padre/Padre/t/75-perl-beginner.t') called at /home/sewi/padre/Padre/lib/Padre/Wx/Main.pm line 1644
Padre::Wx::Main::on_run_this_test('Padre::Wx::Main=HASH(0x954abb8)') called at /home/sewi/padre/Padre/lib/Padre/Wx/Menu/Run.pm line 78
Padre::Wx::Menu::Run::ANON('Padre::Wx::Main=HASH(0x954abb8)', 'Wx::CommandEvent?=SCALAR(0xbbdb830)') called at /home/sewi/padre/Padre/lib/Padre/Action.pm line 101
Padre::Action::_event('Padre::Action=HASH(0x9589dd8)', 'Padre::Wx::Main=HASH(0x954abb8)', 'Wx::CommandEvent?=SCALAR(0xbbdb830)') called at (eval 356) line 1
Padre::Action::ANON('Padre::Wx::Main=HASH(0x954abb8)', 'Wx::CommandEvent?=SCALAR(0xbbdb830)') called at /home/sewi/padre/Padre/lib/Padre.pm line 185
eval {...} called at /home/sewi/padre/Padre/lib/Padre.pm line 185
Padre::run('Padre=HASH(0x88ce928)') called at /home/sewi/padre/Padre/script/padre line 81

Ubuntu 9.04
Padre trunk r8464

Change History

comment:1 Changed 5 years ago by Sewi

  • Status changed from new to closed
  • Resolution set to not a bug

Appears only with ProcessStream? - versions below 0.20

0.20 fails tests (at least on Ubuntu), but seems to run anyway.

Note: See TracTickets for help on using tickets.