Ticket #697 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 3 years ago

put plugins in sandbox so they cannot take down padre

Reported by: szabgab Owned by:
Priority: critical Milestone:
Component: plugins Version: 0.48
Keywords: Cc:

Description

There are cases when an exception in a plugin takes down the whole padre process.

I think we should at least wrap each call to a plugin with an eval block to eliminate the most common crashes.

Change History

comment:1 Changed 3 years ago by zenogantner

  • Type changed from defect to enhancement
  • Component changed from editor to plugins

comment:2 Changed 3 years ago by zenogantner

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #615

Note: See TracTickets for help on using tickets.