Opened 5 years ago

Closed 4 years ago

#704 closed defect (fixed)

Segfault when closing documentation dialog

Reported by: nuba Owned by:
Priority: minor Milestone:
Component: POD based help Version: 0.48
Keywords: crash Cc:

Description

nuba@nubatop2:~$ padre
Deep recursion on anonymous subroutine at /usr/local/share/perl/5.8.8/Padre/Wx/DocBrowser.pm line 436.
Deep recursion on subroutine "Padre::Wx::DocBrowser::_close" at /usr/local/share/perl/5.8.8/Padre/Wx/DocBrowser.pm line 155.
Segmentation fault

steps:

fresh padre install, following the instructions at http://padre.perlide.org/trac/wiki/Download#Ubuntu

launch padre
add 'use Moose'
enable the outline sidebar
go to modules, expand, choose moose
right click, open documentation
on the documentation dialog window, click on the close button (usually X) provided by the window manager

Additional info:

This is perl, v5.8.8 built for i486-linux-gnu-thread-multi

Wx Version=(0.93) wxWidgets 2.8.10 unicode=(1)

uname -a: Linux nubatop2 2.6.24-24-generic #1 SMP Tue Jun 30 20:28:53 UTC 2009 i686 GNU/Linux

This is a Ubuntu 8.04.3 LTS

Change History (4)

comment:1 Changed 4 years ago by zenogantner

  • Keywords crash added

I can reproduce this with the current trunk version of Padre on Ubuntu 10.04.

comment:2 Changed 4 years ago by zenogantner

Padre output now looks like this:

Deep recursion on anonymous subroutine at /usr/local/share/perl/5.10.1/Padre/Wx/Browser.pm line 163.
Deep recursion on subroutine "Padre::Wx::Browser::on_close" at /usr/local/share/perl/5.10.1/Padre/Wx/Browser.pm line 140.
[1]+  Segmentation fault      padre

comment:3 Changed 4 years ago by szabgab

fixed in r14130 in 0.85
thanks for reporting and sorry for the delay.

comment:4 Changed 4 years ago by szabgab

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.