Opened 10 years ago

Closed 10 years ago

#759 closed defect (invalid)

Flicker when typing in Padre

Reported by: run4flat Owned by:
Priority: minor Milestone:
Component: editor Version: 0.52
Keywords: Cc:

Description

When typing in Padre, my current line (and sometimes the next line) flickers. It's rather hard to describe, but I've attached (hopefully) a video that shows what's going on.

I speculate that the current and next line are being grayed out so that they can be redrawn.

Attachments (1)

Padre-flicker.ogv (171.9 KB) - added by run4flat 10 years ago.
Simple example movie that shows the flicker effect. The flicker is much faster than what's recorded here, but no less obnoxious.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by run4flat

Simple example movie that shows the flicker effect. The flicker is much faster than what's recorded here, but no less obnoxious.

comment:1 Changed 10 years ago by Sewi

Please check your preferences settings, the following (and others) might cause this:

  • autocomplete always
  • smart highlighting
  • Perl syntax tooltips
  • syntax checker

Try to turn them off and look if it helps.

I'd like to know the speed of your CPU.

All of this is just a guess, but might be worth a try.

comment:2 Changed 10 years ago by run4flat

  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from 0.50 to 0.52

Hey Sewi, I tried various permutations of autocomplete, smart highlighting, and syntax checker, but any combination of those didn't help. I could not find the syntax tooltips option to check/uncheck, so I can't tell you about that.

My system has two 3.06 GHz P4 processors with 3 GB ram. The flickering in the recording is much slower than what happens in real time because the system was bogged down with the recording process when I made that demo.

I also installed Padre on another Ubuntu computer and it worked without the flickering, so I figured that it's a botched install on my first box. (CPAN is great but it's not as robust as I'd like.) So I did what I did with my laptop: installed Padre from the Ubuntu repositories (so it pulls in whatever dependencies I need) and then do a CPAN upgrade. And yet it still flickers.

I need to reiterate that this is not a reproducible bug, because Padre does not flicker on my other Ubuntu machine. Therefore, for now, I am going to mark this bug as invalid, though I'll be happy to continue hacking at it if you have other ideas. Something tells me that a 'fresh install' would get things working, but I'm not exactly sure what I mean when I say that. Reinstall all of Perl on this machine...? Maybe I should take 5.11 for a spin...

David

Note: See TracTickets for help on using tickets.