Ticket #825 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Directroy Tree Search locks up Padre when no documents are opened

Reported by: waxhead Owned by:
Priority: major Milestone:
Component: Project Browser Version: trunk
Keywords: Cc:

Description

When you first start Padre or when there is only the one new unsaved document, try searching in the Directory Tree Pane.

The search will then start to consume resources with Padre "greying out" as the window become unresponsive.

Change History

comment:1 Changed 4 years ago by waxhead

  • Version changed from 0.54 to trunk

Adam said this is due to the number of files in the current directory:

The problem is the entire directory tree runs in the foreground
On a regular refresh, it doesn't descend into subdirectories, so it's containable
You only notice if you have a project with a zillion things in the root path
Like when some applications generate a temp file and immediately open it in Padre, and the temp path has 1000+ files in it
But on a search, it has to scan recursively
Which takes a long time
...for the first character
After the first character, it uses a filtering process
This is a known problem

comment:2 Changed 4 years ago by waxhead

Just tried this out, certainly not causing the problem it was before.

This is using trunk as of r11789.

comment:3 Changed 4 years ago by waxhead

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 3 years ago by szabgab

  • Component changed from editor to Project Browser
Note: See TracTickets for help on using tickets.