Opened 5 years ago

Closed 3 years ago

#831 closed defect (fixed)

CPAN Install, test failing caused by Term::Readline

Reported by: vrobin Owned by: szabgab
Priority: minor Milestone:
Component: Debug::Client Version: 0.55
Keywords: Cc: burakgursoy@…

Description

Trying to install Debug::Client, I had to force the installation. Tracking down the problem, it seems that there's a warning displayed from Term::ReadLine? in the debugger output that made most of the tests fail.

The problem can be workaround either by setting TERM environment variable to dumb ( set TERM=dumb ) or by forcing install.

Error returned by the debugger:

C:\strawberry\cpan\build\Debug-Client-0.11-4Yc8_t>perl -d t\eg\01-add.pl

Loading DB routines from perl5db.pl version 1.32
Editor support available.

Enter h or `h h' for help, or `perldoc perldebug' for more help.

main::(t\eg\01-add.pl:4):       $| = 1;

'''SetConsoleMode failed, LastError=|6| at C:\strawberry\perl\vendor\lib/Term/ReadKey.pm line 274.
 at C:\strawberry\perl\vendor\lib/Term/ReadLine/readline.pm line 1580'''
        readline::readline('  DB<1> ') called at C:\strawberry\perl\vendor\lib/Term/ReadLine/Perl.pm line 11
        Term::ReadLine::Perl::readline('Term::ReadLine::Perl=ARRAY(0x4c27bc)', '  DB<1> ') called at C:/strawberry/perl/
lib/perl5db.pl line 6499
        DB::readline('  DB<1> ') called at C:/strawberry/perl/lib/perl5db.pl line 2237
        DB::DB called at t\eg\01-add.pl line 4
  DB<1> h
  
  DB<1> s
main::(t\eg\01-add.pl:6):       my $x = 1;

Detail of the cpan install failing:

  CPAN.pm: Going to build S/SZ/SZABGAB/Debug-Client-0.11.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for Debug::Client
cp lib/Debug/Client.pm blib\lib\Debug\Client.pm
  SZABGAB/Debug-Client-0.11.tar.gz
  C:\strawberry\c\bin\dmake.EXE -- OK
Running make test
C:\strawberry\perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib\lib', 'blib\arch')" t/*.t
t/00-internal.t ....... ok
t/01-add.t ............ # PID -2784
t/01-add.t ............ 1/8 Debug::Client: Line is undef. Buffer is '' at t/01-add.t line 37
# Looks like you planned 8 tests but ran 3.
# Looks like your test exited with 255 just after 3.
t/01-add.t ............ Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 5/8 subtests
t/02-sub-step_out.t ... Unknown error at C:\strawberry\cpan\build\Debug-Client-0.11-4Yc8_t\blib\lib/Debug/Client.pm line
 368.
t/02-sub-step_out.t ... 1/19 # Looks like you planned 19 tests but ran 2.
# Looks like your test exited with 10053 just after 2.
t/02-sub-step_out.t ... Dubious, test returned 69 (wstat 17664, 0x4500)
Failed 17/19 subtests
t/02-sub-step_over.t .. Debug::Client: Line is undef. Buffer is '' at t/02-sub-step_over.t line 33
t/02-sub-step_over.t .. 1/14 # Looks like you planned 14 tests but ran 2.
# Looks like your test exited with 255 just after 2.
t/02-sub-step_over.t .. Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 12/14 subtests
t/02-sub.t ............ 1/26 Debug::Client: Line is undef. Buffer is '' at t/02-sub.t line 24
# Looks like you planned 26 tests but ran 1.
# Looks like your test exited with 255 just after 1.
t/02-sub.t ............ Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 25/26 subtests
t/03-return.t ......... Unknown error at C:\strawberry\cpan\build\Debug-Client-0.11-4Yc8_t\blib\lib/Debug/Client.pm line
 368.
t/03-return.t ......... 1/13 # Looks like you planned 13 tests but ran 2.
# Looks like your test exited with 10053 just after 2.

Environment version:

C:\strawberry>perl -v

This is perl, v5.10.1 (*) built for MSWin32-x86-multi-thread

Copyright 1987-2009, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.


C:\strawberry> perl -MWx -e"printf(qq(Wx Version=($Wx::VERSION) %s unicode=(%s)\n), Wx::wxVERSION_STRING(), Wx::wxUNICODE())"
Wx Version=(0.96) wxWidgets 2.8.10 unicode=(1)

C:\strawberry>

Change History (2)

comment:1 in reply to: ↑ description Changed 4 years ago by burak

  • Cc burakgursoy@… added

I got similar errors (ActivePerl? 5.10.1.1006) TERM=dumb seems to work for me too. Perhaps something like:

$ENV{TERM} = 'dumb' if ! exists $ENV{TERM};

can be used inside the module?

comment:2 Changed 3 years ago by bowtie

  • Resolution set to fixed
  • Status changed from new to closed

vrobin, thanks for the heads up

Term::ReadLine
Term::ReadLine::Perl

added to Debug:Client-0.15

see: http://matrix.cpantesters.org/?dist=Debug-Client%200.15

Note: See TracTickets for help on using tickets.