Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#833 closed defect (fixed)

Syntax error crash padre when trying to debug

Reported by: vrobin Owned by: szabgab
Priority: major Milestone:
Component: Debugger for Perl 5 Version: 0.76
Keywords: Cc:

Description

If I try to step into this buggy script, padre closes unexpectedly with no warning. For this to work, you have to check "use external windows for execution".

The error message of the debugged script:

syntax error at J:\documents\Projects\workspace\mda-tools\Perl\MDACl\test.pl line 14, near ") azeazeafdf"
Execution of J:\documents\Projects\workspace\mda-tools\Perl\MDACl\test.pl aborted due to compilation errors.
 at J:\documents\Projects\workspace\mda-tools\Perl\MDACl\test.pl line 14
Appuyez sur une touche pour continuer...

The killing script:

use strict;

use Getopt::Long;

my $man = 0;
my $help = 0;
my $exporterName;
my $albumDir; 

GetOptions(				'help|?' => \$help, 
					'man' => \$man,
					'album-dir|d=s' => \$albumDir,
					'data-exporter|de=s' => \$exporterName
					) azeazeafdf; 

For environment, see ticket 831.

Change History (4)

comment:1 Changed 5 years ago by szabgab

  • Component changed from editor to Debug::Client
  • Owner set to szabgab
  • Status changed from new to assigned

comment:2 Changed 4 years ago by dandv

  • Version changed from 0.55 to 0.76

Still happens in 0.76 with a simple script like:

use strict;

printt "crash";

Stepping in, or "Run till Breakpoint" reproduce the silent crash/die/exit.

comment:3 Changed 4 years ago by azawawi

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r13451

Thanks for reporting it,
Ahmad M. Zawawi

comment:4 Changed 3 years ago by bowtie

  • Component changed from Debug::Client to Debugger for Perl 5
Note: See TracTickets for help on using tickets.