Ticket #857 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Vista: The Ack window dings annoyingly

Reported by: adamk Owned by: azawawi
Priority: critical Milestone:
Component: editor Version: 0.56
Keywords: Cc:

Description

The list control in the Ack window emits a ding/system-beep every single time any line gets clicked.

It is so incredibly annoying that it renders the Ack window almost unusable.

As a point of comparison, the list in the Advanced Preferences dialog shows the same behaviour, but no other list in Padre seems to do this.

Change History

comment:1 Changed 4 years ago by azawawi

Vista or win7?

comment:2 Changed 4 years ago by azawawi

  • Owner set to azawawi
  • Status changed from new to assigned

comment:3 Changed 4 years ago by azawawi

  • Status changed from assigned to closed
  • Resolution set to duplicate

Wx::ListView? and Wx::ListCtrl? exhibit the same behavior in common controls v5 so yes you can move Ack window to Wx::ListBox?...

This is already fixed for padre.exe in win32\wperl.exe.manifest. Setting it as Duplicate of ticket:856. Reopen if you think otherwise :)

Note: See TracTickets for help on using tickets.