Ticket #870 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

Padre crashs when closing "Open Resource" with the 'x' button from window manager

Reported by: rehsack Owned by:
Priority: major Milestone:
Component: Wx::Perl::Dialog Version: 0.57
Keywords: Cc:

Description

Deep recursion on anonymous subroutine at /usr/pkg/lib/perl5/vendor_perl/5.10.0/Padre/Wx/DocBrowser.pm line 439.
Deep recursion on subroutine "Padre::Wx::DocBrowser::_close" at /usr/pkg/lib/perl5/vendor_perl/5.10.0/Padre/Wx/DocBrowser.pm line 158.

[1]+ Segmentation fault (core dumped) padre

$ perl -v

This is perl, v5.10.1 (*) built for x86_64-netbsd-thread-multi
Wx Version=(0.9701) wxWidgets 2.8.10 unicode=(1)

Padre is built from pkgsrc (pkg from OS vendor)

Change History

comment:1 Changed 4 years ago by zenogantner

I cannot reproduce this on Ubuntu 10.04 with the latest version of Padre.
Do you still have this problem?

comment:2 Changed 4 years ago by rehsack

Give me some time to update my Padre - after FrOSCon ...

comment:3 Changed 3 years ago by zenogantner

Hi, is this still the case?

comment:4 Changed 3 years ago by zenogantner

  • Status changed from new to closed
  • Resolution set to worksforme

I am closing this ticket. If you still encounter the problem, please re-open.

Note: See TracTickets for help on using tickets.