Opened 5 years ago

Closed 4 years ago

#875 closed defect (fixed)

Case insensitive checkbox not taken into account in "Find in Files" dialog

Reported by: karl.forner Owned by:
Priority: major Milestone:
Component: editor Version: 0.57
Keywords: Cc:

Description

In the Search->Find in Files dialog, when the "case insensitive" checkbox is checked, the search is not "case insensitive".

Steps to reproduce it:
run Padre, hit "CTRL+SHIFT+F", type "getpane" in the "term" testfield, Pick the Padre source directory, check the "case insensitive" checkbox then hit find.
It won't find anything in the modules.

Then do it again, but this time type "GetPane?", this time you will get some hits.

Padre 0.57 r10981
This is perl, v5.10.0 built for i486-linux-gnu-thread-multi
Wx::wxVERSION_STRING(), Wx::wxUNICODE())'
Wx Version=(0.94) wxWidgets 2.8.10 unicode=(1)

Attachments (1)

acki.patch (757 bytes) - added by karl.forner 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by karl.forner

  • Resolution set to fixed
  • Status changed from new to closed

made a quick fix. Apply the patch in the trunk directory.
Added error checking on the regexp, now display a messagebox on error, and cancel the dialog.

TODO: add dynamic error checking by adding an event to the dialog textfield.

Changed 5 years ago by karl.forner

comment:2 Changed 5 years ago by karl.forner

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 Changed 4 years ago by submersible_toaster

Appears working in 0.60

comment:4 Changed 4 years ago by zenogantner

Works for me in 0.61/trunk as well.

comment:5 Changed 4 years ago by zenogantner

  • Resolution set to fixed
  • Status changed from reopened to closed

Closed. Please re-open if necessary.

Note: See TracTickets for help on using tickets.