Opened 6 years ago

Closed 6 years ago

#91 closed defect (not a bug)

Tests fail (missing dependancies)

Reported by: hashbangperl Owned by:
Priority: major Milestone:
Component: editor Version: 0.15
Keywords: Tests, Installation, CPAN Cc:

Description

When installing Padre from CPAN, tests fail rather than skip when dependancies missing, also dependancies possibly missing from Makefile.PL

Missing requisites seem to be Class::Autouse and File::HomeDir?

Test output :

Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-compile....skipped

all skipped: Needs Test::Compile 0.08

t/01-load.......Can't locate Class/Autouse?.pm in @INC
at t/01-load.t line 11.
BEGIN failed--compilation aborted at t/01-load.t line 11.
# Looks like your test died before it could output anything.
t/01-load.......dubious

Test returned status 255 (wstat 65280, 0xff00)

DIED. FAILED tests 1-10

Failed 10/10 tests, 0.00% okay

t/02-new........Can't locate File/HomeDir?.pm in @INC at /root/.cpan/build/Padre-0.14/blib/lib/Padre.pm line 210.
BEGIN failed--compilation aborted at /root/.cpan/build/Padre-0.14/blib/lib/Padre.pm line 210.
Compilation failed in require at t/02-new.t line 14.
BEGIN failed--compilation aborted at t/02-new.t line 14.
# Looks like you planned 5 tests but only ran 1.
# Looks like your test died just after 1.
t/02-new........dubious

Test returned status 255 (wstat 65280, 0xff00)

DIED. FAILED tests 2-5

Failed 4/5 tests, 20.00% okay

t/03-wx.........Can't locate File/HomeDir?.pm in @INC
BEGIN failed--compilation aborted at t/03-wx.t line 8.
# Looks like your test died before it could output anything.
t/03-wx.........dubious

Test returned status 255 (wstat 65280, 0xff00)

DIED. FAILED test 1

Failed 1/1 tests, 0.00% okay

t/80-newline....ok
t/81-search.....ok
Failed Test Stat Wstat Total Fail Failed List of Failed


t/01-load.t 255 65280 10 20 200.00% 1-10
t/02-new.t 255 65280 5 8 160.00% 2-5
t/03-wx.t 255 65280 1 2 200.00% 1
1 test skipped.
Failed 3/6 test scripts, 50.00% okay. 15/38 subtests failed, 60.53% okay.
make: * [test_dynamic] Error 255

/usr/bin/make test -- NOT OK

Change History (6)

comment:1 Changed 6 years ago by szabgab

Padre only has Build.PL and the above two files are in there.

Where did you get Makefile.PL from ?

comment:2 Changed 6 years ago by hashbangperl

I downloaded from CPAN..

Looking at the Makefile.PL there is a file containing :
<<<<
# This Makefile.PL has been autogenerated by the module CPAN.pm
# because there was no Makefile.PL supplied.
# Autogenerated on: Mon Nov 3 09:12:44 2008

use ExtUtils::MakeMaker?;
WriteMakefile?(NAME => q[Padre]);

I can see the dependancies in Build.PL, but I guess it wasn't used by my CPAN client (shipped with Fedora 8 :1.76_02 )

comment:3 Changed 6 years ago by szabgab

As I understand this happens on old versions of CPAN.pm

Can you upgrade CPAN.pm (the best to install Bundle::CPAN)

comment:4 Changed 6 years ago by hashbangperl

Updated Bundle::Cpan,

now it's fetching dependancies but I hit the following problem ...

Fetching wxWidgets...
fetching from: http://prdownloads.sourceforge.net/wxwindows/wxWidgets-2.8.8.tar.gz
Fetch failed! HTTP response: 500 Internal Server Error [500 Can't connect to garr.dl.sourceforge.net:80 (connect: Connection refused)] at inc/My/Build/Base.pm line 243

comment:5 Changed 6 years ago by hashbangperl

Cancelled and tried again.. seems to be downloading now.. nevermind

comment:6 Changed 6 years ago by szabgab

  • Resolution set to not a bug
  • Status changed from new to closed

Upgrading CPAN.pm helps

Note: See TracTickets for help on using tickets.