Opened 5 years ago

Closed 3 years ago

#918 closed defect (fixed)

"Reload files" dialog will constantly reopen and nag if there is a deleted file

Reported by: Corion Owned by:
Priority: major Milestone:
Component: editor Version: 0.59
Keywords: Cc:

Description

Padre 0.59 will constantly redisplay the "Some files have changed" nag screen if there is (for example) a deleted file currently open in Padre. This makes Padre mostly unusable if you want to keep a file as buffer in memory while you make other changes.

To reproduce:

  1. Open a file in Padre.
  2. Unlink that file on disk.
  3. Move your mouse in Padre.
  4. The nag screen appears.
  5. Dismiss the nag screen with "Reload" or with "Close"
  6. Move your mouse
  7. Goto 4.

What it should do:

If a file has been found to be in a state (deleted, changed), Padre should not ask for that file again, until its state really has changed again (deleted, changed).

Change History (2)

comment:1 Changed 4 years ago by waxhead

I'm not a real fan of this implementation with the file list popping up like it does.

I'd rather that each document was handled independently as the document becomes active, this is how notepad++ handles it.

I did try the above, it seems to be doing the right thing in terms of not asking again once the dialog is closed/actioned.

This was on trunk, post 0.61 release.

comment:2 Changed 3 years ago by adamk

  • Resolution set to fixed
  • Status changed from new to closed

It still nags a fair bit, but not "constantly"

Note: See TracTickets for help on using tickets.