Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#922 closed defect (fixed)

Regex editor keeps first language after language change.

Reported by: zenogantner Owned by:
Priority: minor Milestone:
Component: Regex Editor Version: trunk
Keywords: i18n Cc:

Description

How to reproduce:

  1. Open Regex Editor
  2. Close Regex Editor
  3. Select another language from "View"->"Language"
  4. Open Regex Editor

The Regex Editor is still in the first language.

This does not happen with the preferences dialog or the keyboard combination dialog.

Change History (4)

comment:1 Changed 4 years ago by zenogantner

The About box has the same problem.

comment:2 Changed 4 years ago by zenogantner

I guess this is because Padre::Wx::Dialog::Preferences is a Padre::Wx::Dialog,
while the other ones (Key Bindings, About, RegexEditor?) inherit just from Wx::Dialog.
I haven't spotted the code yet that makes the difference.
I'd be grateful for any hints on that matter.

comment:3 Changed 4 years ago by zenogantner

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r13289

comment:4 Changed 4 years ago by szabgab

  • Component changed from advanced perl tools to Regex Editor
  • Keywords regex editor removed
Note: See TracTickets for help on using tickets.