Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#935 closed defect (fixed)

[PerlTidy plugin] Can't install Padre::Plugin::PerlTidy because of missing "default_plugin_dir" field in Padre::Config

Reported by: sjn Owned by:
Priority: minor Milestone:
Component: Perl Tidy Version: 0.60
Keywords: plugin Cc:

Description

tried installing Padre::Plugin::PerlTidy?, and am getting this error:

$ make installplugin
(... time passes ...)
All tests successful.
Files=2, Tests=14, 1 wallclock secs ( 0.04 usr 0.01 sys + 1.02 cusr 0.05 csys = 1.12 CPU)
Result: PASS

adding: man3/ (stored 0%)
adding: man3/Padre::Plugin::PerlTidy?.3pm (deflated 57%)
adding: man3/.exists (stored 0%)
adding: bin/ (stored 0%)
adding: bin/.exists (stored 0%)
adding: lib/ (stored 0%)
adding: lib/auto/ (stored 0%)
adding: lib/auto/share/ (stored 0%)
adding: lib/auto/share/dist/ (stored 0%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy/? (stored 0%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/ (stored 0%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-ar.po (deflated 61%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-ja.mo (deflated 40%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-pt-br.po (deflated 62%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-fr-fr.mo (deflated 44%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-es-es.po (deflated 64%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-ja.po (deflated 57%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-zh-tw.po (deflated 58%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-ar.mo (deflated 43%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-fr-fr.po (deflated 62%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-pl.po (deflated 59%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-nl-nl.po (deflated 64%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-de.po (deflated 60%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-pl.mo (deflated 39%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-es-es.mo (deflated 45%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-de.mo (deflated 44%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-pt-br.mo (deflated 42%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-nl-nl.mo (deflated 46%)
adding: lib/auto/share/dist/Padre-Plugin-PerlTidy?/locale/PadrePluginPerlTidy-zh-tw.mo (deflated 38%)
adding: lib/auto/Padre/ (stored 0%)
adding: lib/auto/Padre/Plugin/ (stored 0%)
adding: lib/auto/Padre/Plugin/PerlTidy/ (stored 0%)
adding: lib/auto/Padre/Plugin/PerlTidy/.exists (stored 0%)
adding: lib/Padre/ (stored 0%)
adding: lib/Padre/Plugin/ (stored 0%)
adding: lib/Padre/Plugin/PerlTidy.pm (deflated 67%)
adding: lib/Padre/Plugin/.exists (stored 0%)
adding: man1/ (stored 0%)
adding: man1/.exists (stored 0%)
adding: MANIFEST (deflated 77%)
adding: META.yml (deflated 44%)
adding: arch/ (stored 0%)
adding: arch/auto/ (stored 0%)
adding: arch/auto/Padre/ (stored 0%)
adding: arch/auto/Padre/Plugin/ (stored 0%)
adding: arch/auto/Padre/Plugin/PerlTidy/ (stored 0%)
adding: arch/auto/Padre/Plugin/PerlTidy/.exists (stored 0%)
adding: arch/.exists (stored 0%)
adding: script/ (stored 0%)
adding: script/.exists (stored 0%)

Successfully created binary distribution '/home/sjn/.cpan/build/Padre-Plugin-PerlTidy?-0.10-tYps15/PerlTidy.par'.
Its contents are accessible in compliant browsers as:

jar:file:///home/sjn/.cpan/build/Padre-Plugin-PerlTidy-0.10-tYps15/PerlTidy.par!/MANIFEST

Can't locate object method "default_plugin_dir" via package "Padre::Config" at inc/Module/Install/PadrePlugin.pm line 121.
make: * [installplugin] Error 9

$ perl -MWx -e'printf(qq(Wx Version=($Wx::VERSION) %s unicode=(%s)\n), Wx::wxVERSION_STRING(), Wx::wxUNICODE())'
Wx Version=(0.96) wxWidgets 2.8.10 unicode=(1)

Change History (7)

comment:1 Changed 4 years ago by zenogantner

  • Component changed from editor to plugins
  • Priority changed from minor to critical

I have the same problem.

comment:2 Changed 4 years ago by zenogantner

  • Priority changed from critical to minor

Installing Module::Install::PadrePlugin? from the directory trunk/Module-Install-PadrePlugin? in the Padre repository fixed the problem.

Don't know whether this is also fixed in the CPAN version of Module::Install::PadrePlugin?.

comment:3 Changed 4 years ago by zenogantner

CPAN has version 0.01 of Module::Install::PadrePlugin?, and with that it also works.
I am still a bit confused why it did not work before, though.

Any ideas?

comment:4 Changed 4 years ago by zenogantner

  • Summary changed from Can't install Padre::Plugin::PerlTidy because of missing "default_plugin_dir" field in Padre::Config to [PerlTidy plugin] Can't install Padre::Plugin::PerlTidy because of missing "default_plugin_dir" field in Padre::Config

comment:5 Changed 4 years ago by szabgab

  • Component changed from plugins to Perl Tidy

comment:6 Changed 3 years ago by bowtie

  • Resolution set to fixed
  • Status changed from new to closed

Padre::Plugin::PerlTidy? works for me and i also presume others who svn to trunk and tidy first.

comment:7 Changed 3 years ago by szabgab

The question if it has been fixed in the released version of the PerlTidy? plugin or to phrase it differently if the fix in the SVN has been released?

I just tried Padre 0.86 and Padre::Plugin::PerlTidy? 0.16 and that pair worked.

Note: See TracTickets for help on using tickets.