Opened 5 years ago

Closed 5 years ago

#941 closed defect (invalid)

Help is improperly formatted/displayed

Reported by: run4flat Owned by:
Priority: major Milestone:
Component: Context Sensitive Help Version: 0.60
Keywords: help display Cc:

Description

My last reported bug was impossible to track down... Hopefully this one won't be so hard. On both of my ubuntu machines, the Padre Help does not format its contents. Initially this was a problem on only one machine, but now that I've upgraded my good machine to Ubuntu 10.04, I am having trouble with it, too.

Why is this a major problem? Because beautifully formatted help is one of the primary reasons I use Padre. Without that, it's still better than the other editors, but not by much.

Attachments (2)

stuff.txt (2.9 KB) - added by run4flat 5 years ago.
Output of perl -V and the other requested command.
Screenshot-Help.png (172.5 KB) - added by run4flat 5 years ago.
Example of improperly formatted help.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by run4flat

Output of perl -V and the other requested command.

Changed 5 years ago by run4flat

Example of improperly formatted help.

comment:1 Changed 5 years ago by run4flat

Sorry, that was a bit harsh. Padre is a great editor, but it is WAY more awesome with the good help system.

comment:2 Changed 5 years ago by zenogantner

My guess this is because of version 0.95 or 0.96 of the Wx Perl bindings.
I suggest you upgrade to 0.97 or later and check whether this problem persists.

See also the discussion on the WxPerl? mailing list: http://www.nntp.perl.org/group/perl.wxperl.users/2010/05/msg7285.html

comment:3 Changed 5 years ago by zenogantner

I have added a version check for Wx.pm during installation in r11472.
If one of the buggy version (0.95, 0.96) is detected, it gives out a warning.

comment:4 Changed 5 years ago by run4flat

  • Resolution set to invalid
  • Status changed from new to closed

Upgrading to Wx 0.97 fixed the problem! This is not a bug with Padre, so I'm going to mark it as invalid. Requiring v 0.97 or newer in the install process would probably be a good idea, though.

Note: See TracTickets for help on using tickets.