Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#967 closed defect (fixed)

Reset focus

Reported by: Sewi Owned by:
Priority: minor Milestone:
Component: editor Version: trunk
Keywords: directory tab, usability, right Cc:

Description

Many doubleclicks on the directory browser, tab panel or function list move the current focus to the panel instead of leaving them at the editor.

A single click on a file or function selects the clicked line, but a double click usually does something with the main editor window and having the focus on a panel is usually not what I want when doing an action with the editor window.

I think this is fresh.

r11889

Change History (8)

comment:1 Changed 4 years ago by zenogantner

  • Keywords directory tab added

comment:2 Changed 4 years ago by zenogantner

With the directory browser and the function list, the focus goes there even with single clicks; at least for me on Ubuntu. Don't know whether this is intended behavior or not.

comment:3 Changed 4 years ago by zenogantner

  • Keywords usability added

I guess single clicks are fine.
We should fix the focus thing, and additionally find a way to go from the editor window to the outline/function list with a keyboard shortcut.

comment:4 Changed 4 years ago by zenogantner

Actually, for outline this works correctly.

comment:5 Changed 4 years ago by zenogantner

For the project browser, double clicks on files cause the focus to be on the editor, which is good.

Double clicks on directories remove the focus, which should be fixed.

comment:6 Changed 4 years ago by zenogantner

  • Keywords right added

The TODO list has the same problem.

comment:7 Changed 4 years ago by zenogantner

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r13759.

comment:8 Changed 3 years ago by zenogantner

The solution did not work properly on Win32, so Adam added another fix in r13830.

Note: See TracTickets for help on using tickets.