Opened 4 years ago

Closed 4 years ago

#970 closed defect (fixed)

Switching language removes plugin menus

Reported by: zenogantner Owned by: zenogantner
Priority: major Milestone:
Component: editor Version: trunk
Keywords: Cc:

Description

How to reproduce:

  1. Start Padre, with some activated modules
  2. Switch to another language via the 'View' menu

Observation:
The plugin entries in the 'Tools' menu are gone.
When switching back to the normal language, they do not reappear.
The plugins are still loaded, which can be verified by opening the plugin manager.

Activating or de-activating any plugin will bring back the menu entries.

This behavior has also been reproduced by waxhead (reported on IRC).

Change History (4)

comment:1 Changed 4 years ago by waxhead

  • Priority changed from minor to major

Looking into this a bit, and not getting overly far with it, when you change languages you see this in the console multiple times:

15:47:08: Error: Cannot set locale to 'de_DE'.

20 to be exact.

I'm not sure where this is coming from, or if it relates to the problems with the plugins being translated correctly, but it might be worth checking into.

You will also see this error in the make test for Padre as well, where the test tries to set a different language.

comment:2 Changed 4 years ago by waxhead

  • Owner set to zenogantner
  • Status changed from new to assigned

Assigning to you, since it looks like you've fixed it.

comment:3 Changed 4 years ago by zenogantner

Still not fixed ;-).

comment:4 Changed 4 years ago by zenogantner

  • Resolution set to fixed
  • Status changed from assigned to closed

Now (0.74, and trunk) it works.

Note: See TracTickets for help on using tickets.