wiki:Download

Version 113 (modified by szabgab, 5 years ago) (diff)

--

We work hard to make the Padre installation simple but it is a large project with lots of dependencies. (See also the Distribution part of the Development page)

Windows

An experimental msi installer for Padre standalone based on Strawberry Perl can be found here:

http://perlide.org/download/binary/padre-standalone-5.10.0.1-beta-1.msi

CPAN

Normally you should be able to just install it as any other Perl module using the CPAN or CPANPLUS shell.

  $ cpan
  cpan> install Padre

but read on!! , many of the dependencies need manual attention and it can take several hours to install it the first time. See further details on this page.

Known issues

with Padre and its dependencies

Alien::wxWdigets and Wx often need to be installed one-by-one manually

On Windows IPC::Run (0.82) hangs sometimes - install it using

  cpan> force install notest IPC::Run

There are some more issues, we should add them here.

Binary

While we would be happy to have many people install Padre from CPAN and then switch to use it from our SVN repository, we also would like to make it easy to start with Padre so we try to provide some binary packages.

Linux in general

There are PAR-generated executables for Linux (both x86_32 and x86-64) that can be downloaded from here: http://www.perlide.org/download/binary

Once you run

chmod +x filename

the files are executable (launch it by double clicking or by full path from shell).

If you built Padre from sources and want to generate such a binary on another architecture for others to use, simply run "make exe" and be patient.

Mandriva

Mandriva 2009.0 comes with pre-packaged Padre 0.10. Mandriva 2009.1 will ship Padre 0.29. Mandriva cooker (development version) is following upstream quite closely.

Jerome Quelin (jq, jquelin) who is both a Padre developer and a Mandriva maintainer keeps Padre up to date in Mandriva.

To install padre:

# urpmi perl-Padre

Fedora

Fedora-11 includes Padre-0.32 with Wx Version: 0.91.

unfortunately the Wx is broken: See

http://jamesmcdonald.id.au/gnu-linux/fedora/wxperl-fedora-11 )

https://bugzilla.redhat.com/show_bug.cgi?id=508496

A fix is available here: https://admin.fedoraproject.org/updates/perl-Wx-0.91-5.fc11

https://admin.fedoraproject.org/pkgdb/packages/name/perl-Padre

Marcela Maslanova (marcela) keeps Padre up to date in Fedora.

To install padre:

# yum install perl-Padre

Debian

Latest Debian package is available at http://packages.debian.org/sid/main/padre

To install Padre on Debian:

Add an "Unstable" source to /etc/apt/sources.list as follows:

deb http://mirror.isoc.org.il/pub/debian/ unstable main contrib non-free
deb-src http://mirror.isoc.org.il/pub/debian/ unstable main contrib non-free

Then update:

# apt-get update

And now - install:

# apt-get install padre

FreeBSD

Because FreeBSD Perl package comes without threads support no official Padre packages are available. The prefered method is to manually recompile Perl port to support threads and then build Padre and all it's dependencies from Ports (see Download).

However there are highly experimental packages available for FreeBSD 6-STABLE and 7-STABLE. Before reading further be warned that you're using them at your own responsibility! Neither Padre developers nor package contributor can be held responsible for any damage done to your computer.

First, make sure you have deinstalled non-threaded Perl package or that you have threaded Perl already compiled. Please note, that after installing threaded Perl all Perl modules already installed have to be recompiled. All packages depends on Perl 5.8.9 (that's the current Perl version for 6 and 7 branches).

First set PACKAGESITE environment variable to point to http://therek.net/freebsd/tb/6-STABLE-i386/All/Latest/ for 6-STABLE or http://therek.net/freebsd/tb/7-STABLE-i386/All/Latest/ for 7-STABLE. Then install packages as usual:

# setenv PACKAGESITE http://therek.net/freebsd/tb/6-STABLE-i386/All/Latest/ # for C Shell
# export PACKAGESITE=http://therek.net/freebsd/tb/6-STABLE-i386/All/Latest/ # for Bourne Shell
# pkg_add -r p5-Padre

Feedback is welcomed.

Source code

Padre is released as a CPAN package. You can download and install it using CPAN.pm or CPANPLUS. The released versions can be seen here http://search.cpan.org/dist/Padre/ and here http://kobesearch.cpan.org/dist/Padre.

As Padre has many dependencies probably the easies is, to install the binary distribution where available from the vendor (Mandriva, Fedora, Debian, FreeBSD) and then use CPAN.pm to upgrade.

If this is not possible read on:

The difficult part will be to install some of the prerequisites:

Mattia Barbon did a great job with them but they are still difficult to install. Any help with this would be welcome. See the wxPerl web site and mailing list.

Additional help can be provided by:

  1. Describing the results you have on various operating systems
  2. Asking the various downstream distributors to include Padre
  3. Creating a stand-alone version using PAR

Help in any of those is appreciated. Please post links to any conversation you might have with the distro maintainers so others can follow up.

MS Windows

Strawberry Perl

Download Strawberry Perl from here: http://www.strawberryperl.com/

On Strawberry Perl 5.10, starting from version 5.10.0.3 you can install Padre by starting the CPAN shell and typing

  cpan> install Padre

Note: installing Padre in a fresh install of Strawberry Perl can lead to weird behaviour, like preferences not being saved on exit (due to Padre crashing on exit). See the comments for #258 for a workaround.

On previous releases of Strawberry Perl 5.10 you can install it following these steps

  cpan> look Alien::wxWidgets
  $ perl Makefile.PL
  $ dmake
  $ dmake test
  $ dmake install
  $ exit
  cpan> look Wx
  $ perl Makefile.PL
  $ dmake
  $ dmake test
  $ dmake install
  $ exit
  cpan> install Padre

Once it is installed you can start Padre either by

Start/Run and type in padre

or by creating a shortcut and then clicking on it.

When creating the shortcut use the following as command:

C:\strawberry\perl\bin\wperl.exe C:\strawberry\perl\bin\padre.bat

note we are using wperl here instead of perl in order to avoid the extra command shell window.

Active Perl

http://www.activestate.com/

Once you have installed Active Perl you need to configure two additional PPM repositories and then you can install Padre using the ppm pacakging system. Let's see how to do it in the Command Shell:

Start/Run/cmd ENTER
ppm rep add wxperl http://www.wxperl.co.uk/repository  
ppm rep add padre  http://www.perlide.org/download/ppm/

ppm install Alien-wxWidgets
ppm install Wx
ppm install Padre

Once that's done you can start Padre by typing

perl c:\perl\site\bin\padre

or

wperl c:\perl\site\bin\padre

Replace "c:\perl" with the path, where Active Perl is installed.

Older Active Perl details

The manual installation is still a bit rough but we are working on improving it.

1) (A) Most of the modules - can be taken from the main ActiveState? Package Repository.

(B) For Active Perl there are prebuilt PPM versions of Alien::wxWidgets and Wx (aka. wxPerl) and can be installed from http://wxperl.co.uk/.

So add the wxperl repository to the PPM: http://www.wxperl.co.uk/repository (for detailed instructions see http://wxperl.co.uk/ppm.html ) (and even more info here http://docs.activestate.com/activeperl/5.10/faq/ActivePerl-faq2.html )

Adding the repository to your PPM repository list: In PPM4 (ActivePerl? 820+) this is most easily done via the GUI menu option: Edit -> Preferences.

If you use PPM3 - or used to command line (==DOS , still usable for PPM4) - you can do:

ppm rep add wxperl http://www.wxperl.co.uk/repository 

2) Install all the packages (except of course perl) listed as "requires" on

http://svn.perlide.org/padre/trunk/Padre/Makefile.PL - by using ppm.

Don't worry about the order of installation and report us any problem you encounter.

You can do in by searching the "requires" packages listed in the above link - either by using the PPM4 GUI, or searching PPM command line (==DOS):

ppm search App::Ack

The result may look like this:

C:\Documents and Settings\orenm>ppm search App::Ack
Downloading ActiveState Package Repository packlist...not modified
1: ack
   A grep-like program specifically for large source trees
   Version: 1.86
   Released: 2008-07-09
   Author: Andy Lester <andy@petdance.com>
   Provide: App::Ack version 1.86
   Require: File::Basename
   Require: File::Next version 0.4 or better
   Require: Getopt::Long
   Require: Term::ANSIColor
   Require: Test::Harness version 2.5 or better
   Require: Test::More
   Repo: ActiveState Package Repository
   CPAN: http://search.cpan.org/dist/ack-1.86/

C:\Documents and Settings\orenm>

So now you shall do:

ppm install ack

3) then open the cpan client and install Padre:

  c:> perl -MCPAN -eshell
  cpan> install Padre

Oren Maurer reported that you might need to force it:

  cpan> force install Padre

at some point you might encounter an error like this:

 Running install for module 'Padre'
 Running make for S/SZ/SZABGAB/Padre-0.06.tar.gz
 CPAN: Digest::SHA loaded ok (v5.45)
 Fetching with LWP:
  http://ppm.activestate.com/CPAN/authors/id/S/SZ/SZABGAB/CHECKSUMS
 Alert: While trying to 'parse' YAML file
  'D:\ActiveState\Perl\cpan\FTPstats.yml'
 with 'YAML::XS' the following error was encountered:
  Usage: YAML::XS::LibYAML::Load(yaml_str) at
 D:\ActiveState\Perl\lib/YAML/XS.pm
  line 70.

The reported solution was this:

  [reach the cpan shell:]
  C:\>cpan
  cpan> o conf yaml_module ''
  cpan> o conf commit
  commit: wrote 'C:\Perl\lib/CPAN/Config.pm'
  cpan> q

(See: http://groups.google.com/group/de.comp.lang.perl.misc/browse_thread/thread/3a347d02a1ebf464 and http://perl.org.il/pipermail/perl/2008-September/009779.html )

Other things that to do and can help:

  1. upgrading last version of Encode - using ppm ,

Note:

For upgrading all PPM packages, do this (Windows command line, a.k.a Dos)

    ppm upgrade --install 
  1. upgrade of Wx - also by using ppm ,
  2. installing Alien-wxWidgets (the same way... ppm),
  3. And now - do (again with ppm):
        ppm install  --force Alien-wxWidgets-dev
    

(See: http://meorero.wordpress.com/2009/02/02/padre-on-ms-windows-with-activeperl-5100-build-1004/)

For more info about "ppm - Perl Package Manager, version 4" - see the ActivePerl? 5.10 Documentation: http://docs.activestate.com/activeperl/5.10/bin/ppm.html

Debian

Latest Debian package is available at http://packages.debian.org/sid/main/padre (see Binary above)

Until it is released, the key is to uninstall all wxwidgets and wxperl related packages, and to install enough of the -dev packages to allow Alien::wxWidgets to build version 2.8.8. Once that works, cpan install Wx and from there Padre should install (see the Subversion quick install instructions above for more)

Ubuntu

Installation of Alien::wxWidgets fails, because configure can't find gtk.h. Simply do:

$ apt-get install libwxgtk2.8-0 libwxgtk2.8-dev libwxbase2.8-dev libwxbase2.8-0

and install these other dependencies available from the Ubuntu repository:

$ apt-get install libmodule-build-perl libextutils-cbuilder-perl libmodule-pluggable-perl g++

For Ubuntu < 8.10, you'll need to compile wxWidgets from source, so install the -dev package for gtk+ 2.0:

$ apt-get install libgtk2.0-dev

finally, install the remaining Perl modules via CPAN:

% sudo cpan ExtUtils::CBuilder Alien::wxWidgets Wx

(NOTE: For Ubuntu < 8.10, be sure to answer "yes" to the following question during the installation of Alien::wxWidgets )

Do you want to fetch and build wxWidgets from sources? [no ]

(NOTE: Although libextutils-cbuilder-perl is available from the repository, it only contains version 0.18, whereas Padre requires version 0.24)

Ubuntu is syncronizing Padre from Debian. See the launchpad for details:

Some more useful links

Fedora

Fedora has wxPerl since at least FC8

Fedora 8 has

  • wxGTK-2.8.7
  • perl-Wx-0.74
  • perl-Alien-wxWidgets-0.31

This should be sufficient:

# rpm -ivh  perl-Wx perl-Alien-wxWidgets

Fedora 9 has

  • wxGTK-2.8.7
  • perl-Wx-0.81
  • perl-Alien-wxWidgets-0.32

This should be sufficient:

# rpm -ivh  perl-Wx perl-Alien-wxWidgets

Mandriva/Mandrake?

Recent versions of Mandriva have Padre packaged - see above.

Mandriva 2008.1

has these:

  • perl-Alien-wxWidgets Version: 0.33-2mdv2008.1
  • perl-Wx Version: 0.81-1mdv2008.1

To install Padre follow these:

# urpmi perl-Alien-wxWidgets
# urpmi perl-Wx
$ cpan
cpan> install Padre

FreeBSD

To run Padre on FreeBSD you have to recompile Perl to support threads (by default Perl on FreeBSD have it disabled). To verify whether your Perl installation have thread support turned on run following command.

$ perl -V:usethreads
usethreads='define';

If the result is define then you have already threaded Perl installed, otherwise execute:

# cd /usr/ports/lang/perl5.8 && make WITH_THREADS=yes
# make deinstall && make reinstall

Optionally you can substitute make WITH_THREADS=yes with following and choose THREADS in the menu, then deinstall and reinstall Perl as above. This have an advantage over the previous method, because prefered configuration options will be stored in your system's packing database. This way next time you'll be building Perl (i.e. updaing) all stored options will be applied without the need to manually specify them.

# make config
# make

To install Padre and it's dependencies just execute:

# cd /usr/ports/editors/p5-Padre
# make install clean

openSUSE

  1. Add the packman repository.
  2. Install the package »wxWidgets-devel« and the schema »C/C++ Development«.

  1. Install Padre from CPAN.

Gentoo

Has Wx version 0.82

http://www.nntp.perl.org/group/perl.wxperl.users/2008/07/msg5993.html

   g-cpan -i Padre

should work but you need a threaded perl. If you have trouble installing please file a bug here or on http://bugs.gentoo.org depending where do you think the problem is.

More detailed instructions:

  1. Make sure your perl is compiled with USE="ithreads" ( generally in /etc/make.conf ) and emerge perl
  2. If you don't have g-cpan installed, emerge app-portage/g-cpan
  3. g-cpan -i Padre

g-cpan often is incapable of properly detecting dependencies. Installing from source often works better:

   emerge dev-perl/Alien-wxWidgets dev-perl/wxperl
   perl -MCPAN -e 'install Padre'

Note: this method is only recommended if g-cpan fails to recursively install dependencies that the CPAN shell would otherwise identify.

Installing Padre from the CPAN shell may upgrade core modules provided by the core Gentoo perl install, so be prepared to downgrade those modules when emerging other packages or upgrading the system. A 'force install Padre' afterwards can help upgrade the conflicts again.

Also, one or more of the modules may require perl 5.10. This is not a part of any portage tree as of yet and can only be found in the perl overlay. See Gentoo Bug#206455.

OS X

On OS X, you cannot use the system's 'perl' executable, you have to use the 'wxPerl' executable (see this thread regarding wxPerl invocation).

Install everything from source

The most straightforward method is to install everything from source. This will ignore any existing wxwidgets installation.

  1. $ wxPerl -MCPAN -eshell
  2. [cpan] $ install Alien::wxWidgets [choose install from source, which is NOT the default]
  3. Go do something else while it compiles wxWidgets.
  4. [cpan] $ install Wx
  5. [cpan] $ install Padre

Padre has a LOT of prerequisites. You're likely to run into some problems with tests failing. IPC::Run3 was a particular problem due to its prerequisites, but a later individual install worked fine. Just make your way through them all, and 'force notest install $module' as needed. Once you've got padre installed you start it by running /usr/local/bin/padre.

Taking the lazy way

If you're lazy and enjoy taking risks... the easiest way to install on OSX may be (there will be some test failures - which you'll have to force install, including Padre itself, due to wxPerl issues):

cpan Alien::wxWidgets
wxPerl -MCPAN -eshell
 $ install Padre

and then replace the /usr/local/bin/padre script with the updated version at http://padre.perlide.org/browser/trunk/Padre/script/padre

If you are risk averse and like playing in your own sandbox, then it is recommended that you download and compile the current release of Perl from source (http://cpan.org/src/README.html). Note: you'll need to run ./Configure with -Dusethreads. After which you won't need to use wxPerl, but can do the standard make, make test, make install of Padre via cpan.


OS X 10.4 has wxPerl 0.22, 10.5 has a more recent version (0.6x for some x)

Aside from building from source, you can also install newer versions of Wx on OS X using a package manager:

Fink

fink install wxmac28

Mac Ports

port install wxWidgets

installing _and_ upgrading wxWidgets and wxPerl

If you have trouble you can check which version of wxWidgets you have:

$ perl -MWx -le'print  "Wx Version: $Wx::VERSION " . Wx::wxVERSION_STRING()'

and on Mac:

$ wxPerl -MWx -le'print  "Wx Version: $Wx::VERSION " . Wx::wxVERSION_STRING()'

We use Wx 0.87 and wxWidgets 2.8.8 so you probably should have those (or newer) too.

When installing Alien::wxWidgets it will ask if you want to compile wxWidgets. Do you want to fetch and build wxWidgets from sources? If you don't have any installed or if you have an old version (< 2.8.8) then you should answer yes. It will try to download the source code of wxWidgets which is big and the download often fails.

To get around that you can download the file manually and put it in the extracted directory of Alien::wxWidgets.

Something like this:

 $ cd /tmp
 $ wget http://prdownloads.sourceforge.net/wxwindows/wxWidgets-2.8.8.tar.gz
 $ cpan
 cpan> look Alien::wxWidgets
 $ cp /tmp/wxWidgets-2.8.8.tar.gz .
 $ perl Makefile.PL
 $ make
 $ make test
 $ make install
 $ exit
 cpan>quit
 $

wxPerl on Linux distributions

More detailed instruction for manual installation

(tested on Debian Lenny)

  • make sure your cpan works - make, gcc, etc
  • make sure you remove all traces of wxWidgets 2.6 from your system
  • install wxwidgets (2.8 or later) - cpan Alien::wxWidgets will download and compile and install it for you
  • install (or upgrade) Wx - cpan Wx
  • install Module::Install (if its not already there)
  • add the following settings to cpan
      o conf build_requires_install_policy yes ;  o conf commit
      o conf prerequisites_policy follow ; o conf commit
    
  • svn co http://svn.perlide.org/padre
  • cd padre/trunk/Padre
  • sudo cpan .
  • ./dev.pl

Attachments (1)

Download all attachments as: .zip