Changes between Version 24 and Version 25 of DownloadUbuntu


Ignore:
Timestamp:
01/10/12 16:32:36 (2 years ago)
Author:
run4flat
Comment:

Added libgtk2.0-dev to required package list, since Wx::Scintilla appeared to require it for some reason, and moved the text about wx-2.6 to a more appropriate location.

Legend:

Unmodified
Added
Removed
Modified
  • DownloadUbuntu

    v24 v25  
    1010* to install the wx library files you can 
    1111{{{#!sh 
    12 $sudo apt-get install libwxbase2.8-0 libwxgtk2.8-0 libwxbase2.8-dev libwxgtk2.8-dev 
     12$sudo apt-get install libwxbase2.8-0 libwxgtk2.8-0 libwxbase2.8-dev libwxgtk2.8-dev libgtk2.0-dev 
    1313}}} 
    1414* you can check the library files are installed with 
     
    1919libwxgtk2.8-0 
    2020libwxgtk2.8-dev 
     21 
     22$ dpkg -l |grep -i libgtk2.0-dev |awk '{ print $2 }' 
     23libgtk2.0-dev 
    2124}}} 
    2225* you will need to reinstall WX. 
     
    3336 
    3437}}} 
    35  
    36 === If you accidentally tried to install with wx-2.6 libs, 
    37 then the installation will die at some point during the Wx compilation phase. In that case, Alien::wxWidgets will think that you have v 2.6 (even after you install 2.8), so you must remove it before moving forward with the install. To check if Alien::wxWidgets is incorrect, run this at your command line: 
    38 {{{#!sh 
    39 perl -MAlien::wxWidgets -e 'print Alien::wxWidgets->version, "\n"' 
    40 }}} 
    41 If the output says 2.006### then Alien::wxWidgets needs to be fixed. If it says 2.008###, then this is not a problem. 
    42  
    43 Before doing any of the following steps, ensure that you have the wx-2.8 dev libs installed via apt-get, as detailed above. The steps that I have tried to fix this problem, in increasing levels of severity, are as follows. After you try each one, you can test if Alien::wxWidgets is properly configured by running the one-liner shown above and checking that the output says 2.008###. 
    44  
    45 * Force-install Alien::wxWidgets. (This didn't work for me for some reason.) 
    46 * Install App::pmuninstall via CPAN and use it to remove Alien::wxWidgets. Then reinstall Alien::wxWidgets. 
    47 * Remove the Alien::wxWidgets files by hand, then re-install Alien::wxWidgets from cpan. If you are using local::lib, you will find these in ~/perl5/lib/perl5/Alien and ~/perl5/lib/perl5/i686-linux-gnu-thread-multi/Alien. If you are installing these into your system perl, you will find these under similar folders at /usr/local/lib/perl5/..., I believe. 
    4838 
    4939== Installation using the Package Manager == 
     
    7767 * Install required development packages  
    7868{{{ 
    79 sudo apt-get install libwxgtk2.8-0 libwxgtk2.8-dev libwxbase2.8-dev libwxbase2.8-0 g++ 
     69sudo apt-get install libwxgtk2.8-0 libwxgtk2.8-dev libwxbase2.8-dev libwxbase2.8-0 libgtk2.0-dev g++ 
    8070}}} 
    8171 * download and setup local::lib ( http://search.cpan.org/dist/local-lib/ ) 
     
    122112 * {{{conf save}}} 
    123113 
     114=== If you accidentally tried to install with wx-2.6 libs 
     115This can happen if you blindly try to install Padre using cpan without checking for library dependencies. In that case, the installation will die at some point during the Wx compilation phase. Alien::wxWidgets will think that you have v 2.6 (even after you install 2.8), so you must remove it before moving forward with the install. To check if Alien::wxWidgets is incorrect, run this at your command line: 
     116{{{#!sh 
     117perl -MAlien::wxWidgets -e 'print Alien::wxWidgets->version, "\n"' 
     118}}} 
     119If the output says 2.006### then Alien::wxWidgets needs to be fixed. If it says 2.008###, then this is not a problem. 
     120 
     121Before doing any of the following steps, ensure that you have the wx-2.8 dev libs installed via apt-get, as detailed above. The steps that I have tried to fix this problem, in increasing levels of severity, are as follows. After you try each one, you can test if Alien::wxWidgets is properly configured by running the one-liner shown above and checking that the output says 2.008###. 
     122 
     123* Force-install Alien::wxWidgets. (This didn't work for me for some reason.) 
     124* Install App::pmuninstall via CPAN and use it to remove Alien::wxWidgets. Then reinstall Alien::wxWidgets. 
     125* Remove the Alien::wxWidgets files by hand, then re-install Alien::wxWidgets from cpan. If you are using local::lib, you will find these in ~/perl5/lib/perl5/Alien and ~/perl5/lib/perl5/i686-linux-gnu-thread-multi/Alien. If you are installing these into your system perl, you will find these under similar folders at /usr/local/lib/perl5/..., I believe. 
     126 
     127 
     128 
    124129== Still Not Working? == 
    125130Following the instructions on this page did not lead to a successful installation?