wiki:Features/BasicEditorFeatures
Last modified 3 years ago Last modified on 03/31/11 10:10:59

Basic Editor Features

  • File -> New or Ctrl+N to create a new empty file. A file name is not needed at this point. By default Padre will treat the file as a Perl 5 file.
  • File -> Open or Ctrl+O to navigate the file system and open an existing files. Padre will use the file extension to recognize the file type. It will also apply certain heuristics to determine if a file without an extension and files with extensions that are use for several file types. In particular, Padre will try to guess if the file is a Perl 5 or a Perl 6 file.
  • File -> Open ->
  • File -> Open -> Open Selection or Ctrl+Shift+O if there is a selected text this will try to locate files that match the selection. If the selection looks like a path Padre will try to open that path either absolute or relative. If it looks like a module name (Some::Thing) it will try to find the appropriate file Some/Thing?.pm in @INC and open it. currently this feature opens the first file encountered.

(TO DO it should find all the possibilities and if there are multiple hits offer the user to choose. This will be especially important if we are working on a module that is also already installed. Padre might find the installed version first while we might want to open the development version.)

(TO DO: when the file is not of Perl type we should have other ways to recognize files from internal naming and have paths to search. Surprise, not every language uses @INC.)

  • File -> Reload File - Reloads the file. This is interesting if you either made changes and want to discard them

and/or if the file has changed on the disk. If there are unsaved changes Padre will ask you if you really want to throw them away. (TO DO: make a backup of the file before discarding it)

  • File -> Save or Ctrl+S will save the current file. If the file does not have a name yet, Padre will open a

directory browser to let you pick the name of the file. If you are currently working on a project then in certain cases Padre will try to determine the name of the file by itself. See ProjectManagement for more details.

  • File -> Save As... or F12 will open a directory browser and let you find a new locations and give a new name

to save the file. If the file was changed already in the editor the changes will only be saved to the new file and the old file will remain as it was before. After saving the file with a new name any subsequent saves will go to this new file.

  • File -> Save All or Alt+F12 will save all the files currently open. If there are one or more tabs open with content but without a filename, Padre will prompt for a name for each one of the files.
  • File -> Close or Ctrl+W checks if the file is saved, if it is closes the current tab. If it is not then offers to save it first.
  • File -> Close -> Close all Files - closes all opened files (in case they are not saved yet, asks for instructions).
  • File -> Close -> Close All but Current - closes all opened files except for the currently being edited.
  • Files -> Recent Files - a list of recently opened files to open them easily. (TO DO: update the list when we open a file, not only when opening padre) (TO DO: allow the user to configure size of history)
  • File -> Document Statistics - just random statistics about the current document. If you miss anything important let us know!
  • File -> Quit - Exits Padre

Simple editing

The simple editing features (should) provide the expected behavior for Windows users.

  • Edit -> Undo or Ctrl+Z
  • Edit -> Redo
  • Edit -> Select -> Select All or Ctrl+A, select all the characters in the current document
  • Edit -> Cut or Ctrl+X
  • Edit -> Copy or Ctrl+C
  • Edit -> Paste or Ctrl+V

(TO DO What is Ctrl+D ?, duplicate the current line?)

  • Edit -> Convert Line Endings -> - Convert line endings to Windows, Unix or Mac Classic style.
  • Edit -> Toggle Comment or Shit+Ctrl+C
  • Edit -> Comment Selected Lines or Ctrl+M
  • Edit -> Uncomment Selected Lines or Ctrl+Shift+M

Case Changes

Change the case of the selected text or if there is no selection all the text in the current file.

  • Edit -> Upper/Lower? Case -> Upper All - Change all characters to upper case
  • Edit -> Upper/Lower? Case -> Lower All - Change all characters to lower case

Change the first character of every word to upper/lower case leaving the rest as they were. (used to be in a plug-in?)

Tickets

Ticket Resolution Summary Owner Reporter
#1474 worksforme UNABLE TO RUN THE PERL SCRIPT THE IN THE PADRE PERL IDE C_PRASANNA
#1473 change in indent does not update until padre is closed and opened davehorner
#1453 Scrolling in main window broken on windows nglenn
#1394 Unexpected program termination when selecting menu items fenway
#1336 UI Layout - Lock/Unlock Behaviour ktaragorn
#1333 More understandable Settings : Auto Complete Brackets ktaragorn
#1322 cannot reproduce Fix use of UNIVERSAL in t/collection/Config-Tiny/t/02_main.t ofosos
#1262 The combo keys for type a backslash (\) on OS X with french keyboard raises the contextual menu Sniper
#1259 osx Padre icon toolbar default should be same as linux (default to true) tome tome
#1258 cannot reproduce [osx] opening the plugin manager results in a wxWidgets Debug Alert tome
#1257 fixed OSX Preferences window opens at maximize and cannot be resized tome
#1256 fixed OSX Padre menu keybindings are missing / not clear tome tome
#1177 Allow the user to set the default mime-type szabgab
#1112 Remember manually selected mime-type - "View Document As" szabgab
#1027 save file with .pl extension by default? waxhead szabgab
#244 open file, remember path szabgab