Changes between Version 1 and Version 2 of PreReleaseChecklist


Ignore:
Timestamp:
02/10/11 13:05:04 (3 years ago)
Author:
zenogantner
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • PreReleaseChecklist

    v1 v2  
     1What to report 
     2 * for each single item 
     3 ** OK or 
     4 *** crashes 
     5 *** inconsistent behaviour 
     6 *** actions that do not work as expected 
     7 * for each section 
     8 ** How much time did it take you to perform the tests? 
     9 
    110Preparation 
    2 # fresh Padre installation 
     111. fresh Padre installation 
    312 
    413Perl 5 scripts 
    5 # open a Perl script 
    6 # run it by hitting F5 
    7 # activate syntax checks 
    8 # introduce a syntax error and inspect resulting output 
     14 1. open a Perl script 
     15 1. run it by hitting F5 
     16 1. activate syntax checks 
     17 1. introduce a syntax error and inspect resulting output 
     18 1. click on the syntax error to jump to the position of the error 
    919 
    1020Perl 5 modules 
    11 # open a large Perl module (e.g. from the Padre source) 
    12 # activate the function list 
    13 # double-click on a function name to jump to its location in the file 
    14 # activate the outline view 
    15 # double-click on a method name to jump to its location in the file 
     21 1. open a large Perl module (e.g. from the Padre source) 
     22 1. activate the function list 
     23 1. double-click on a function name to jump to its location in the file 
     24 1. activate the outline view 
     25 1. double-click on a method name to jump to its location in the file 
     26 
     27Perl projects 
     28 1. open the project browser 
     29 1. browse the directories of the project 
     30 1. open a file from the project 
     31 1. save it under another name 
     32 1. delete the newly created file 
     33 
     34Text files 
     35 1. "File" -> "New" 
     36 1. save it as {{{file.txt}}} 
     37 1. save it as {{{file}}} 
     38 1. use "Edit" -> "Go To ..." to jump to a given line 
     39 1. use "Edit" -> "Go To ..." to jump to a given character position 
     40 
     41Perl distributions and templates and running 
     42 1. create a new Perl 5 distribution: "File" -> "New" -> "Perl Distribution ..." 
     43 1. create a "hello, world" style Perl 5 module: "File" -> "New" -> "Perl 5 Module" 
     44 1. create a test for the module: "File" -> "New" -> "Perl 5 Test" 
     45 1. use "File" -> "Save Intuition" to save the module 
     46 1. run the test: "Run" -> "Run Tests" 
     47 1. run the test: "Run" -> "Run and Build Tests" 
     48 1. create a new Perl 5 script that uses the module: "File" -> "New" -> "Perl 5 Script" 
     49 1. run it: "Run" -> "Run Script" 
     50 1. run it: "Run" -> "Run Script (Debug Info)" 
     51 1. add an infinite loop the the script 
     52 1. run the script and abort it using F6 
     53 
     54Sessions 
     55 1. cycle through the files using the keyboard: Ctrl-PageUp and Ctrl-PageDown 
     56 1. save the session 
     57 1. close one tab 
     58 1. go to "File" -> "Recent Files" and re-open the file 
     59 1. close all tabs 
     60 1. load the session that you saved before