wiki:PreReleaseChecklist

Version 27 (modified by azornik, 4 years ago) (diff)

--

General

Reports by version and tester

What to report

  • for each single item
    • OK or
      • crashes
      • inconsistent behaviour
      • actions that do not work as expected
  • for each section
    • How much time did it take you to perform the tests?

System information

Preparation

  1. fresh Padre installation
  2. check whether you are running the to-be-released Padre version by opening the "About" box

Test Cases

Perl 5 scripts

  1. open a Perl script (using Ctrl-o or File/Open?)
  2. run it by hitting F5
  3. change to the other output variant (external window or internal pane) (Tools/Preferences/Run? Parameters/Use? external window for execution)
  4. run it by hitting Shift-F5
  5. enable syntax checks (View/Show? Syntax Check)
  6. introduce a syntax error and inspect resulting output
  7. click on the syntax error to jump to the position of the error
  8. enable autocomplete at "Tools"->"Preferences"->"Autocomplete"
  9. start typing a word which is already in the file (maybe "warn" from "warnings")
  10. hit Ctrl-Space, select a suggestion and confirm it
  11. enable bracket autocomplete at "Tools"->"Preferences"->"Behavior"
  12. type ( [ { " ' - each of them should get its closing part automatically

Perl 5 modules

  1. open a large Perl module from the Padre source
  2. enable "View"->"Show Functions"
  3. double-click on a function name to jump to its location in the file
    • the text cursor should be at the corresponding function in the file
  4. enable "View"->"Show Outline"
  5. double-click on a method name to jump to its location in the file
    • the text cursor should be at the corresponding location in the file

Perl projects

  1. enable the project browser: "View"->"Show Project Browser/Tree?"
  2. browse the directories of the Padre project
  3. open a file from the project
  4. save it under another name
  5. check if the file appears in the Project Browser window
  6. delete the newly created file (using the tools of your operating system)
  7. observe that the listing of the file has disappeared from the Project browser
  8. load file using "Search" -> "Open Resource ..."

Text files

  1. "File" -> "New"
  2. save it as file.txt
  3. save it as file
  4. load a text file from disk
  5. use "Edit" -> "Go To ..." to jump to a given line
  6. use "Edit" -> "Go To ..." to jump to a given character position

Saving perl file without extension forgets its mime-type (see #1107)

  1. "File" -> "New"
  2. type in
    #!/usr/bin/perl
    use strict;
    use warnings;
    
  3. save it as file
  4. Check if the mime-type (3rd box on the status bar) says "Perl 5"
  5. Close the file
  6. Open The file using "File" -> "Open"
  7. Check if the mime-type (3rd box on the status bar) says "Perl 5"
  8. Open The file using "File" -> "Save As"
  9. save it as file2
  10. Check if the mime-type (3rd box on the status bar) says "Perl 5"

Perl distributions and templates and running

  1. create a new Perl 5 distribution: "File" -> "New" -> "Perl Distribution ..."
  2. create an additional "hello, world" style Perl 5 module in the same namespace: "File" -> "New" -> "Perl 5 Module"
  3. use "File" -> "Save Intuition" to save the module
  4. create a test for the module: "File" -> "New" -> "Perl 5 Test"
  5. run the test: "Run" -> "Run Tests"
  6. run the test: "Run" -> "Run and Build Tests"
  7. create a new Perl 5 script that uses the module: "File" -> "New" -> "Perl 5 Script"
  8. run it: "Run" -> "Run Script"
  9. run it: "Run" -> "Run Script (Debug Info)"
  10. add an infinite loop the the script
  11. run the script and abort it using F6

Sessions

  1. cycle through the files using the keyboard: Ctrl-PageUp? and Ctrl-PageDown?
  2. save the session
  3. close one tab
  4. go to "File" -> "Recent Files" and re-open the file
  5. close all tabs
  6. load the session that you saved before

Padre server

  1. start Padre
  2. "Tools" -> "Preferences": enable "Open Files in existing Padre"
  3. restart Padre
  4. type padre SOME_FILE in the command line (should open in the same instance of Padre)
  5. "Tools" -> "Preferences": disable "Open Files in existing Padre"
  6. restart Padre
  7. type padre SOME_FILE in the command line (should start a new instance of Padre)

The Command Line Window

  1. enable the command line window. View -> Show Command Line Window.
  2. press ? to get the list of commands.
  3. :! cmd - run command in shell. do :! ls to get the list of files and dirs.
  4. :e file name - open file. do ;e Padre.pm (or every other file) to open the file on padre.
  5. :history - shows the history of all the commands.
  6. :keycatcher Number - shows the value of a single event.
  7. :padre cmd - runs a perl command. example: :padre Padre::Current->main->message("hi").