wiki:PreReleaseChecklist

Version 43 (modified by azornik, 4 years ago) (diff)

--

General

Reports by version and tester

What to report

  • for each single item
    • OK or
      • crashes
      • inconsistent behaviour
      • actions that do not work as expected
  • for each section
    • How much time did it take you to perform the tests?

System information

Preparation

  1. fresh Padre installation
  2. check whether you are running the to-be-released Padre version by opening the "About" box

Test Cases

Perl 5 scripts

  1. open a Perl script (using Ctrl-o or File/Open?)
  2. run it by hitting F5
  3. change to the other output variant (external window or internal pane) (Tools/Preferences/Run? Parameters/Use? external window for execution)
  4. run it by hitting Shift-F5
  5. enable syntax checks (View/Show? Syntax Check)
  6. introduce a syntax error and inspect resulting output
  7. click on the syntax error to jump to the position of the error
  8. enable autocomplete at "Tools"->"Preferences"->"Autocomplete"
  9. start typing a word which is already in the file (maybe "warn" from "warnings")
  10. hit Ctrl-Space, select a suggestion and confirm it
  11. enable bracket autocomplete at "Tools"->"Preferences"->"Behavior"
  12. type ( [ { " ' - each of them should get its closing part automatically

Perl 5 modules

  1. open a large Perl module from the Padre source
  2. enable "View"->"Show Functions"
  3. double-click on a function name to jump to its location in the file
    • the text cursor should be at the corresponding function in the file
  4. enable "View"->"Show Outline"
  5. double-click on a method name to jump to its location in the file
    • the text cursor should be at the corresponding location in the file

Perl projects

  1. enable the project browser: "View"->"Show Project Browser/Tree?"
  2. browse the directories of the Padre project
  3. open a file from the project
  4. save it under another name
  5. check if the file appears in the Project Browser window
  6. delete the newly created file (using the tools of your operating system)
  7. observe that the listing of the file has disappeared from the Project browser
  8. load file using "Search" -> "Open Resource ..."

Text files

  1. "File" -> "New"
  2. save it as file.txt
  3. save it as file
  4. load a text file from disk
  5. use "Edit" -> "Go To ..." to jump to a given line
  6. use "Edit" -> "Go To ..." to jump to a given character position

Saving perl file without extension forgets its mime-type (see #1107)

  1. "File" -> "New"
  2. type in
    #!/usr/bin/perl
    use strict;
    use warnings;
    
  3. save it as file
  4. Check if the mime-type (3rd box on the status bar) says "Perl 5"
  5. Close the file
  6. Open The file using "File" -> "Open"
  7. Check if the mime-type (3rd box on the status bar) says "Perl 5"
  8. Open The file using "File" -> "Save As"
  9. save it as file2
  10. Check if the mime-type (3rd box on the status bar) says "Perl 5"

Perl distributions and templates and running

  1. create a new Perl 5 distribution: "File" -> "New" -> "Perl Distribution ..."
  2. create an additional "hello, world" style Perl 5 module in the same namespace: "File" -> "New" -> "Perl 5 Module"
  3. use "File" -> "Save Intuition" to save the module
  4. create a test for the module: "File" -> "New" -> "Perl 5 Test"
  5. run the test: "Run" -> "Run Tests"
  6. run the test: "Run" -> "Run and Build Tests"
  7. create a new Perl 5 script that uses the module: "File" -> "New" -> "Perl 5 Script"
  8. run it: "Run" -> "Run Script"
  9. run it: "Run" -> "Run Script (Debug Info)"
  10. add an infinite loop the the script
  11. run the script and abort it using F6

Sessions

  1. cycle through the files using the keyboard: Ctrl-PageUp? and Ctrl-PageDown?
  2. save the session
  3. close one tab
  4. go to "File" -> "Recent Files" and re-open the file ( #1143, #1148 )
  5. close all tabs
  6. load the session that you saved before

Padre server

  1. start Padre
  2. "Tools" -> "Preferences": enable "Open Files in existing Padre"
  3. restart Padre
  4. type padre SOME_FILE in the command line (should open in the same instance of Padre)
  5. "Tools" -> "Preferences": disable "Open Files in existing Padre"
  6. restart Padre
  7. type padre SOME_FILE in the command line (should start a new instance of Padre)

The Command Line Window

  1. enable the command line window. View -> Show Command Line Window.
  2. press ? to get the list of commands.
  3. :! cmd - run command in shell. do :! ls to get the list of files and dirs.
  4. :e filename - open file. do :e Padre.pm (or every other file) to open the file on padre.
  5. :history - shows the history of all the commands.
  6. :keycatcher Number - shows the value of a single event.
  7. :padre cmd - runs a perl command. example: :padre Padre::Current->main->message("hi").

Code Folding

View -> Show Code Folding. by enabling code folding padre will put ':' at the end of every statement(unless you already put it). (statement example;

my $x=5; print (" x is now $x");

)

Whites paces

View -> Show Whitespaces by enabling white spaces pare will put a dot each time you click on the "Space" button. also white spaces will show you an arrow each time you click on the "Tab" button.

Word Wrap

View -> Word-Wrap. by enabling word wrap, padre wont let you expand the code block horizontally, if you'll try it will go to the next line.

Indentation Guide

View -> Show Indentation Guide. by enabling it you will see a vertical lines that will show you where a block starts and ends.

Right Margin

View -> Show Right Margin. by enabling it, padre will show you a vertical line after N characters (e.g. N = 80).

To-Do List

View -> To-Do List. opens a to-do list window.

Right Margin

  1. Start padre.
  2. Write a script or open perl module.
  3. Enable Right Margin View -> Show Right Margin.
  4. Go to Tools -> Preferences.
  5. There are 3 buttons at the bottom "Save", "Advanced" and "Cancel". Press the "Advanced" button.
  6. Write down on the filter's search box "right_margin_column" and press it.
  7. The default is "80" change the value to "150" than press "Set" and than press "Save". you will see that the right margin has moved to the right.
  8. Now go back to the right_margin_column (has we done in 4-6) and now Press "Reset" and than press "Save".
  9. Now it should go back to default (value = 80), middle of the screen.

Current Line

First Option

  1. Start padre.
  2. Write a script or open perl module.
  3. Enable Current Line View -> Show Current Line.
  4. Go to Tools -> Preferences.
  5. On the left side you'll have a list of options, go to "Appearance".
  6. There you'll have "Editor Current Line Background Colour" and on the right you can pick the new colour you want, pick a colour(yellow is the default) than Press the "Ok" button and than Press the "Save" button.

Second Option

  • CHECK THE TICKET ABOUT THAT OPTION FIRST! #1150
  1. Start padre.
  2. Write a script or open perl module.
  3. Enable Right Margin View -> Show Current Line.
  4. Go to Tools -> Preferences.
  5. There are 3 buttons at the bottom "Save", "Advanced" and "Cancel". Press the "Advanced" button.
  6. Write down on the filter's search box "editor_currentline_colour" and press it.
  7. than you can change the value(= colour of the "Current Line) to "#FF0000" (Red).
  8. than Press the button "Set" and after that Press the Button "Save" on the bottom.
  • DO NOT FORGET TO CHECK THE TICKET ABOUT THAT OPTION #1150

Syntax highlighting

#1109

  1. In Tools/Preferences/Files? and Colors Select File Type: Perl 5 Select Highlighter: Scintilla

  1. Using File/Open? open the file t/files/no_strict.pl
  2. The status bar at the bottom should now show: the name of the file | Scintilla | Perl 5 | (and some more)
  3. In Tools/Preferences/Files? and Colors Select File Type: Perl 5 Select Highlighter: PPI Experimental
  4. Viewing the already open no_strict.pl file the status bar at the bottom should now show: the name of the file | PPI Experimental | Perl 5 | (and some more) The coloring of the code has changed.
  1. In Tools/Preferences/Files? and Colors Select File Type: Perl 5 Select Highlighter: PPI Standard
  2. Viewing the already open no_strict.pl file the status bar at the bottom should now show: the name of the file | PPI Standard | Perl 5 | (and some more)

TODO: add screenshots with default highlighting of the various syntax highlighers

TODO: other programming languages