wiki:PreReleaseChecklist

Version 73 (modified by szabgab, 3 years ago) (diff)

--

General

Reports by version and tester

Prepare for the testing

If you'd like to test the current development version of Padre then please check it out as

svn co http://svn.perlide.org/padre/trunk/Padre

and then run it from there.

If you'd like to test the release branch then please check out the release branch:

svn co http://svn.perlide.org/padre/branches/Padre-0.84/

Do the regular things:

perl Makefile.PL
make
make test

and then launch padre using

perl -Ilib script/padre

Other possibility is to actually install the release candidate using

make install

and then launch by just typing

padre

What to report

  • for each single item
    • OK or
      • crashes
      • inconsistent behaviour
      • actions that do not work as expected
  • for each section
    • How much time did it take you to perform the tests?

System information

Preparation

  1. fresh Padre installation
  2. check whether you are running the to-be-released Padre version by opening the "About" box

Test Cases

Perl 5 scripts

  1. open a Perl script (using Ctrl-o or File/Open?)
  2. run it by hitting F5
  3. change to the other output variant (external window or internal pane) (Tools/Preferences/Run? Parameters/Use? external window for execution)
  4. run it by hitting Shift-F5
  5. enable syntax checks (View/Show? Syntax Check)
  6. introduce a syntax error and inspect resulting output
  7. click on the syntax error to jump to the position of the error
  8. enable autocomplete at "Tools"->"Preferences"->"Autocomplete"
  9. start typing a word which is already in the file (maybe "warn" from "warnings")
  10. hit Ctrl-Space, select a suggestion and confirm it
  11. enable bracket autocomplete at "Tools"->"Preferences"->"Behavior"
  12. type ( [ { " ' - each of them should get its closing part automatically

Perl 5 modules

  1. open a large Perl module from the Padre source
  2. enable "View"->"Show Functions"
  3. double-click on a function name to jump to its location in the file
    • the text cursor should be at the corresponding function in the file
  4. enable "View"->"Show Outline"
  5. double-click on a method name to jump to its location in the file
    • the text cursor should be at the corresponding location in the file

Project Browser (Perl 5 projects)

  1. Launch Padre
  2. Close all files using File/Close/Close? all files
  3. Open the project browser using "View"->"Show Project Browser/Tree?"
  4. A window should open on the left hand side of Padre
  5. It should be empty (TBD. I am not sure this is a good behavior)
  6. Open the Makefile.PL of the Padre project using Ctrl-O
  7. The project browser window should be filled with the directory tree of Padre
  8. close Makefile.PL
  9. The project browser window should become empty (TBD. should it become empty?)
  10. Now open the share/styles/default.yml in the Padre project
  11. The project browser should show the directory of the Padre project again
  12. browse the directories of the Padre project
  13. open a file from the project by double-clicking on its name in the project browser
  14. save it under another name using F12
  15. check if the file appears in the Project Browser window
  16. delete the newly created file (using the tools of your operating system, outside of Padre)
  17. observe that the listing of the file has disappeared from the Project browser
  18. load file using "Search" -> "Open Resource ..."

Open Resource

  1. Open Padre
  2. Open Padre.pm from the Padre source code
  3. Search/Open? Resource
  4. You should see a window with a text box at the top
  5. Type in the letter 'x'
  6. You should see a list of files from the Padre project in the lower part of the window, all having letter 'x' in their name
  7. add the letter 'y' after the x and all the names should disappear
  8. remove the letter 'x'
  9. It should now show only files with the letter 'y' in them (=> bug it now shows 01_compile.t)
  10. click on the first filename in the list and then move to the other items using the Up/Down? arrows.
  11. Observe that the path to the actual file appears in the third field of the window.
  12. Double click on one of the files
  13. Observe that the file opens in Padre
  1. Open the "Open Resource" window again using Shift-Ctrl-R
  2. Type in 0 (zero)
  3. See the files appearing
  4. Using the 'Down' arrow move to the lower window
  5. select a file
  6. press ENTER to open the file in padre

TBD: I don't know how should this behave if there is no open file

Text files

  1. "File" -> "New"
  2. save it as file.txt
  3. save it as file
  4. load a text file from disk
  5. use "Edit" -> "Go To ..." to jump to a given line
  6. use "Edit" -> "Go To ..." to jump to a given character position

Saving perl file without extension needs to remember its mime-type

See #1107, #849

  1. "File" -> "New"
  2. type in
    #!/usr/bin/perl
    use strict;
    use warnings;
    
  3. save it as file
  4. Check if the mime-type (3rd box on the status bar) says "Perl 5"
  5. Close the file
  6. Open The file using "File" -> "Open"
  7. Check if the mime-type (3rd box on the status bar) says "Perl 5"
  8. Open The file using "File" -> "Save As"
  9. save it as file2
  10. Check if the mime-type (3rd box on the status bar) says "Perl 5"
Who Padre version system status
szabgab r13895 Ubuntu 10.10 fail #1107
  1. Repeat the above but this time the content of the file should be
    #!/usr/bin/env perl
    
    print 42;
    
  1. A third time in which case the content should be
    #!/usr/local/bin/perl
    
    print "ok";
    

Perl distributions and templates and running

  1. create a new Perl 5 distribution: "File" -> "New" -> "Perl Distribution ..."
  2. create an additional "hello, world" style Perl 5 module in the same namespace: "File" -> "New" -> "Perl 5 Module"
  3. use "File" -> "Save Intuition" to save the module
  4. create a test for the module: "File" -> "New" -> "Perl 5 Test"
  5. run the test: "Run" -> "Run Tests"
  6. run the test: "Run" -> "Run and Build Tests"
  7. create a new Perl 5 script that uses the module: "File" -> "New" -> "Perl 5 Script"
  8. run it: "Run" -> "Run Script"
  9. run it: "Run" -> "Run Script (Debug Info)"
  10. add an infinite loop the the script
  11. run the script and abort it using F6

Sessions

TODO: For further description see http://mail.perlide.org/pipermail/padre-dev/2011-February/002433.html and expand this test-case

  1. cycle through the files using the keyboard: Ctrl-PageUp? and Ctrl-PageDown?
  2. save the session
  3. close one tab
  4. go to "File" -> "Recent Files" and re-open the file ( #1143, #1148 )
  5. close all tabs
  6. load the session that you saved before

Padre server

  1. start Padre
  2. "Tools" -> "Preferences": enable "Open Files in existing Padre"
  3. restart Padre
  4. type padre SOME_FILE in the command line (should open in the same instance of Padre)
  5. "Tools" -> "Preferences": disable "Open Files in existing Padre"
  6. restart Padre
  7. type padre SOME_FILE in the command line (should start a new instance of Padre)

The Command Line Window

  1. enable the command line window. View -> Show Command Line Window.
  2. press ? to get the list of commands.
  3. :! cmd - run command in shell. do :! ls to get the list of files and dirs.
  4. :e filename - open file. do :e Padre.pm (or every other file) to open the file on padre.
  5. :history - shows the history of all the commands.
  6. :keycatcher Number - shows the value of a single event.
  7. :padre cmd - runs a perl command. example: :padre Padre::Current->main->message("hi").

Code Folding

View -> Show Code Folding. by enabling code folding padre will put ':' at the end of every statement(unless you already put it). (statement example;

my $x=5; print (" x is now $x");

)

Whites paces

View -> Show Whitespaces by enabling white spaces pare will put a dot each time you click on the "Space" button. also white spaces will show you an arrow each time you click on the "Tab" button.

Word Wrap

View -> Word-Wrap. by enabling word wrap, padre wont let you expand the code block horizontally, if you'll try it will go to the next line.

Indentation Guide

View -> Show Indentation Guide. by enabling it you will see a vertical lines that will show you where a block starts and ends.

TODO List

Features/TODOList

Right Margin

  1. Start padre.
  2. Write a script or open perl module.
  3. Enable Right Margin View -> Show Right Margin.
  4. Go to the Advanced Preferences editor via 'Tools/Preferences/Advanced?'.
  5. In the 'Filter' type "right_margin_column" and click on the item 'editor_right_margin_column'
  6. At the bottom of the screen you will see the details of this option
  7. The default is "80" change the value to "150" than press "Set" and than press "Save". you will see that the right margin mark has moved to the right.
  8. Now go back to the Advanced Preferences Editor select the editor_right_margin_column again and press "Reset" and than press "Save".
  9. Now it should go back to default (value = 80), middle of the screen.

Current Line

First Option

  1. Start padre.
  2. Write a script or open perl module.
  3. Enable Current Line View -> Show Current Line.
  4. Go to Tools -> Preferences.
  5. On the left side you'll have a list of options, go to "Appearance".
  6. There you'll have "Editor Current Line Background Colour" and on the right you can pick the new colour you want, pick a colour(yellow is the default) than Press the "Ok" button and than Press the "Save" button.

Second Option

See #1150

  1. Start padre.
  2. Write a script or open perl module.
  3. Enable Right Margin View -> Show Current Line.
  4. Go to Tools -> Preferences.
  5. There are 3 buttons at the bottom "Save", "Advanced" and "Cancel". Press the "Advanced" button.
  6. Write down on the filter's search box "editor_currentline_colour" and press it.
  7. than you can change the value(= colour of the "Current Line) to "#FF0000" (Red).
  8. than Press the button "Set" and after that Press the Button "Save" on the bottom.

Syntax highlighting

#1109

  1. In Tools/Preferences/Files? and Colors Select File Type: Perl 5 Select Highlighter: Scintilla
  2. Using File/Open? open the file t/files/no_strict.pl
  3. The status bar at the bottom should now show: the name of the file | Scintilla | Perl 5 | (and some more)
  4. In Tools/Preferences/Files? and Colors Select File Type: Perl 5 Select Highlighter: PPI Experimental
  5. Viewing the already open no_strict.pl file the status bar at the bottom should now show: the name of the file | PPI Experimental | Perl 5 | (and some more) The coloring of the code has changed.
  6. In Tools/Preferences/Files? and Colors Select File Type: Perl 5 Select Highlighter: PPI Standard
  7. Viewing the already open no_strict.pl file the status bar at the bottom should now show: the name of the file | PPI Standard | Perl 5 | (and some more)
Who Padre version system status
szabgab r13895 Ubuntu 10.10 OK

TODO: add screenshots with default highlighting of the various syntax highlighers

TODO: other programming languages

Setting the title bar

Padre allows the configuration of the window title and provides placeholders for various values. The actual template can be set in Tools/Preferences/Apperance/Window? title The available placeholders are:

  • %p - Project name
  • %v - Padre version
  • %f - Current filename
  • %d - Current file's dirname
  • %b - Current file's basename
  • %F - Current filename relative to project

strings that look like placeholder but are not supported yet will appear verbatim.

See #1153, #1138, and #1104

  1. In Tools/Preferences/Apperance? Set the Window title to
    • %b - %f - %p - %d - %F - %v - %x - %%
  2. Open a file in the Padre project (e.g. lib/Padre.pm)
  3. Check if the title displays the correct information
    • Padre.pm - path/to/lib/Padre.pm - ??? - lib - lib/Padre.pm - ??? - %x - %%
  4. Create a new file (File/New?)
  5. Check if the title displays the correct information

TBD

Searching and Replacing

Features/SearchAndReplace

Debugging a Perl 5 script

TBD by szabgab

Related #928, #929, #930, #931, #1005, #1036, #1083, #1085, #1086

Installing CPAN modules

TBD by szabgab

Related #501, #1031, #1044, #1045

Refactoring

Features/RefactoringPerl5

Regex Editor

Features/RegexEditor

Perl Tidy

Features/PerlTidy

Perl Critic

Features/PerlCritic